Todoist - Tasks on the web and desktop apps are showing up as duplicates – Incident details

Tasks on the web and desktop apps are showing up as duplicates

Resolved
Operational
Started 19 days agoLasted about 2 hours

Affected

Web application & API

Degraded performance from 1:00 PM to 2:50 PM

Updates
  • Resolved
    Resolved

    The issue with duplicated tasks has been resolved in app version 7007. We recommend that users log out and back in to update the app and remove the duplicates. We are sincerely sorry for any disruption caused 🙏

  • Update
    Update

    If you're seeing duplicates, please try logging out and back in again. This should solve the issue.

    We're still working on a fix to prevent it from happening entirely.

  • Identified
    Identified

    A release from earlier today is causing some users to see duplicated tasks. Please refrain from deleting any duplicates; it should be a visual error. We've identified the cause and are rolling out a fix.