Todoist - Delay in updating or inconsistency in the activity log. – Incident details

Experiencing partially degraded performance

Delay in updating or inconsistency in the activity log.

Identified
Degraded performance
Started about 3 hours ago

Affected

Web application & API

Degraded performance from 10:30 AM to 12:00 AM

Content Sync API

Degraded performance from 10:30 AM to 12:00 AM

Updates
  • Identified
    Identified

    We have pinpointed the possible cause of the issue, and plans are in place to release an improvement while monitoring the situation. We will update you again once we confirm that the problem has been resolved.

  • Investigating
    Investigating

    We are currently experiencing an issue with the activity log page. Recent activity updates are delayed or not showing at the moment. You might also notice inconsistencies in the history. We believe there will be no data loss, but our team is working on a solution. We apologize for the inconvenience.