Scheduled for May 11, 2024 at 7:00 AM – 7:30 AM
Affects
Web application & API
Under maintenance from 7:00 AM to 7:30 AM
Content Sync API
Under maintenance from 7:00 AM to 7:30 AM
- Completed May 11, 2024 at 7:30 AM
- Completed - May 11, 2024 at 7:30 AM- Maintenance has completed successfully 
 
- In progress May 11, 2024 at 7:00 AM
- In progress - May 11, 2024 at 7:00 AM- Maintenance is now in progress 
 
- Planned May 11, 2024 at 7:00 AM
- Planned - May 11, 2024 at 7:00 AM- We’ll apply service updates to our data storage servers. As a result, Todoist’s servers may not be available during this maintenance window. Don’t worry, if you’re logged in, you can still use Todoist offline during this period, and your data will automatically sync when the maintenance ends.